WARNING: This product contains nicotine.
Nicotine is an addictive chemical.
18+ to purchase
V2 is designed with you in mind. V2 is the leading e-cigarette brand, delivering genuine satisfaction with authentic flavors and unparalleled performance.
Vapor Couture Collection Vapor Couture is the original e-cigarette for women, inspiring an entire line of fashionable accessories.
V2 PRO V2 PRO is the world’s most advanced line of vaporizers, representing the ultimate in form and function.
Members and Visitors: We've updated our forum category names to help you easily navigate discussions topics. Categories are still in the same order on the homepage, just with different names! Message me with any questions. - Samantha
Interested in joining the conversation? CLICK HERE to become a forum member now!

Series 3 not recognising the loose leaf cartridge

I was wondering if anyone can help me. I have a V2 pro series 3 which I use with an eliquid cartridge and a loose leaf cartridge. It’s all worked great until tonight - when turning on the series 3 (pressing 3 times)with the loose leaf cartridge in then holding down to activate the red light with turns to Amber and green as it heats, instead it glows white as if I was holding it down using eliquid. I’ve tried the two recommended resets posted in the website but it didn’t work.
Has anyone else experienced this/ got a fix for this?
Many thanks

Comments

  • alexneedshelpalexneedshelp Posts: 2Member
    Yes! I have this happen to. Haven’t had a fix yet. I called the company and they just sent me a new one. The new one does it too though....
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Powered by Vanilla